back to indexDuffmanThe CollectorClobber Girl LisaStretch Dude BartLucy Lawless'Dolittle' WiggumOriginal Homer
Original MargeOriginal BartOriginal LisaOriginal Maggie

<< previous : next >>
Chief Wiggum, 'Dolittle' Wiggum

Name:  Chief Wiggum, 'Dolittle' Wiggum (Wiggum)
Release Info:  Exclusive, 2003 rel. 2003
Item Code:  F0169
Description:  Chief Wiggum dressed like Doctor Dolittle from the Be Sharps episode.
Voiced By:  Hank Azaria
Articulation:  4 points - neck, left shoulder, right shoulder, waist
Accessories:mic (Krusty/Wiggum)
 mic stand
 top hat (Wiggum)
Unique Phrases:  4
Compatibility Ratio:  1 / 39 environments
Packaging:  Boxed (T.R.U. exclusive)

Show Mark's Masterlist Info >>

 Be Sharp Centennial all pegs

"*pant* Where we goin'? Where we goin'? *pant* Noooo, noooooooo! Nooooooooooooo! (howling)" [Homer's Barbershop Quartet]

"Get the tear gas." [Homer's Barbershop Quartet]

"The Be Sharps! *laugh* *laugh* Well, you can't blame a guy for tryin'! *laugh* Well, you're all under arrest!" [Homer's Barbershop Quartet]

"This bird's gonna fly!" [Homer's Barbershop Quartet]

Total Phrases (incl. duplicates): 4

Verified Incompatible Environments:

THOH 4: Collector's Lair
Aztec Theatre
Original Simpsons
Future Burns
Nuclear Power Plant Lunch Room

Total Verified Incompatible:  5

- Install the Akbar Font

Your continued use of this site is considered an agreement with our current privacy and usage policies.

Copyright © 2001-2009, Simpsons Collector Sector. All rights reserved. "The Simpsons" is a registered trademark of 20th Century Fox Film Corp. and "World of Springfield" is a registered trademark of Playmates Toys -- this website is in no way affiliated with either company or any other company whose products or services are represented here.

Can't see the menu? Try the site without styles

The browser you are using does not support the CSS stylesheet specifications used extensively in this site's design. This site will look much better (screenshot) in a browser that supports web standards, such as Internet Explorer 5.5+ or Netscape 6+, but it is accessible to any browser or Internet device. We recommend that you upgrade at your earliest convenience. If you have any questions or need assistance, feel free to email us.